vim ubuntu YouCompleteMe 补全 静态分析 C++    发布于 2017-11-15   641人围观   0条评论

0x00 环境

  • 系统:ubuntu14.04或者ubuntu16.04
  • vim --version查看是否支持python2或者3,并且vim版本大于等于7.4.143

0x01 安装YCM

一般有两种安装方式,推荐使用第一种

通过Vundle安装YCM

安装 Vundle插件

  1. git clone https://github.com/VundleVim/Vundle.vim.git ~/.vim/bundle/Vundle.vim

在vim的配置文件 ~/.vimrc添加插件

  1. call vundle#begin()
  2. " 其他插件
  3. Plugin 'Valloric/YouCompleteMe’
  4. " 其他插件
  5. call vundle#end()

配置完.vimrc保存,并运行:PluginInstall安装插件,该插件安装时间较长,须耐心等待

通过git安装YCM

下载 (在 ~/.vim/bundle 目录下)

$ git clone --recursive https://github.com/Valloric/YouCompleteMe.git

检查完整性(在 ~/.vim/bundle/YouCompleteMe 目录下)

$ git submodule update --init --recursive

0x02 下载最新版的libclang的预编译二进制文件

如果不需要C系语言的语义补全,则跳过0x02,否则继续

下载libclang的预编译二进制文件(version >= 3.9)

找个地方存放,比如我将解压之后的文件存放在~/download/ycm_tmp_clang_llvm/目录下,其下有bin,include,lib,libexec,share文件夹。

0x03 编译安装ycm_core库

安装编译YCM core库所需要的依赖

  1. # python的开发包
  2. sudo
查看更多